cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinod D <vinodd2...@yahoo.com>
Subject Re: No binding factory for namespace registered.
Date Mon, 01 Jun 2009 16:37:53 GMT




________________________________

From: Vinod D <vinodd2009@yahoo.com>
To: users@cxf.apache.org
Sent: Sunday, May 31, 2009 11:55:34 PM
Subject: No binding factory for namespace registered.

Hello:

I am running into an exception in web service client. I am using cxf 2.1.3 where a service
is using XML binding. On the client side I get the wsdl by invoking serviceUrl?wsdl and create
a service. When it creates a port it runs into this exception. Trace is below:

     [java] Caused by: org.apache.cxf.service.factory.ServiceConstructionException
     [java]     at org.apache.cxf.frontend.ClientFactoryBean.create(ClientFactoryBean.java:59)
     [java]     at org.apache.cxf.frontend.ClientProxyFactoryBean.create(ClientProxyFactoryBean.java:102)
     [java]     at org.apache.cxf.jaxws.JaxWsProxyFactoryBean.create(JaxWsProxyFactoryBean.java:115)
     [java]     at org.apache.cxf.jaxws.ServiceImpl.createPort(ServiceImpl.java:434)
     [java]     at org.apache.cxf.jaxws.ServiceImpl.getPort(ServiceImpl.java:312)
     [java]     ... 4 more
     [java] Caused by: org.apache.cxf.BusException: No binding factory for namespace 
registered.
     [java]     at org.apache.cxf.binding.BindingFactoryManagerImpl.getBindingFactory(BindingFactoryManagerImpl.java:91)
     [java]     at org.apache.cxf.frontend.AbstractWSDLBasedEndpointFactory.createEndpoint(AbstractWSDLBasedEndpointFactory.java:114)
     [java]     at org.apache.cxf.frontend.ClientFactoryBean.create(ClientFactoryBean.java:52)
     [java]     ... 8 more

Not clear what namespace it is referring to by "" (i..e empty string)

On client side in cxf.xml I am importing following resources 

<importresource="classpath:META-INF/cxf/cxf.xml"/><importresource="classpath:META-INF/cxf/extensions.xml"/><importresource="classpath:META-INF/cxf/cxf-extension-xml.xml"/>

On server and client side I am pretty much including all jar files from lib and modules directory
in from cxf-2.1.3 distro.

Any help on what I may be missing.

thanks
-Vinod

Some more observation below:

I see this issue if in client I create service using wsdl obtained from serviceUrl?wsdl. However
if I specify wsdl location from file system, it works fine and as expected. This makes me
think that service which I am publishing using endpoint.publish(..) is not exposing the correct
service / wsdl. 

Any help/clue to investigate further is appreciated.

thanks.


      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message