cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Macke <>
Subject Axis2 client is not working with a CXF server
Date Thu, 18 Jun 2009 13:55:12 GMT


I wrote a simple service using the JAX-WS API.

@WebService(targetNamespace = "urn:xastory:csm:contract")
public interface CatalogueStockManagementService {
	net.atos.xastory.csm.contract.WithdrawProductOutput withdrawProducts(
			net.atos.xastory.csm.contract.WithdrawProductInput input)
			throws net.atos.xastory.csm.contract.ServiceException;

Technical Environment:
- CXF 2.0.11
- Tomcat 5.5
- JAXB 2.0

I tried to used this service with a Axis2-based client using JAX-WS.

public void testAxis2Jaxws() throws Exception{
	URL wsdl = new
	QName qname = new QName("",
	Service service = Service.create(wsdl, qname);
	CatalogueStockManagementService catalogueService =

	WithdrawProductInput input = new WithdrawProductInput();
	//fill the input object

	WithdrawProductOutput output = catalogueService.withdrawProducts(input);

>From the server side, input is null. I tried with a CXF-based client, I'm
getting the input properly filled. 

Here is the SOAP request generated by the CXF client:
<soap:Envelope xmlns:soap="">
            <ns1:withdrawProducts xmlns:ns1="urn:xastory:csm:contract">
                  <arg0 xmlns="urn:xastory:csm:contract">

Here is the SOAP request generated by the Axis2 client:
<?xml version='1.0' encoding='UTF-8'?>
                  <arg0 xmlns="">

In Axis2 the xmlns attribute is empty for the arg0 element. CXF seems not
able to treat requests with an empty xmlns in the arg0 element.

Do you have any idea to solve this problem?



View this message in context:
Sent from the cxf-user mailing list archive at

View raw message