cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Clegg <and...@nervechannel.com>
Subject Re: Suddenly, a problem with my cxf-servlet.xml
Date Thu, 12 Feb 2009 12:18:04 GMT
2009/2/12 Andrew Clegg <andrew@nervechannel.com>:

> Now, I can go to http://cxf.apache.org/schemas/jaxws.xsd in my browser
> and it's fine.
>
> But when I highlight this URL in the xsi:schemaLocation in Eclipse,
> and hit F3 for go-to-definition, I see:
>
>
> Not Found
>
> The requested URL /schemas/jaxws.xsd" was not found on this server.
> Apache/2.2.9 (Unix) Server at cxf.apache.org Port 80
>
>
> Note the spurious double-quote mark at the end of the URL.

I've solved (?) this problem with Eclipse's internal browser not
loading the page properly, by putting a space between the URL in the
schemaLocation and the final double-quote.

However the Eclipse error still remains, with the same content:

Multiple annotations found at this line:
       - schema_reference.4: Failed to read schema document
'http://cxf.apache.org/schemas/jaxws.xsd', because 1) could not find
the document; 2) the document could not be read; 3) the root element
of the document is not <xsd:schema>.
       - cvc-complex-type.2.4.c: The matching wildcard is strict, but
no declaration can be found for element 'jaxws:endpoint'.

I have even tried reverting my cxf-servlet.xml from SVN as it was
error free right through yesterday, but no change. Has any change been
made to the web server or the schema at cxf.apache.org which would
cause this?

Thanks again,

Andrew.


-- 
:: http://biotext.org.uk/ ::

Mime
View raw message