cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sertic Mirko, Bedag" <Mirko.Ser...@bedag.ch>
Subject AW: WSDL first results in javax.wsdl.WSDLException
Date Thu, 28 Aug 2008 08:10:05 GMT
Hi

Thank you for your response.

I tried the wsdl validator from 2.1.1 and it says "Passed Validation : Valid WSDL". I also
tried with 2.1.2, and it also passed the validation, but I am still getting the Exception.

Is there something I have to consider when I am using CXF with Spring? Here is my spring config:

<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans"
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	xmlns:jaxws="http://cxf.apache.org/jaxws"
	xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
http://cxf.apache.org/jaxws http://cxf.apache.org/schemas/jaxws.xsd">

	<import resource="classpath:META-INF/cxf/cxf.xml"/> 
	<import resource="classpath:META-INF/cxf/cxf-extension-http.xml" /> 
    <import resource="classpath:META-INF/cxf/cxf-extension-soap.xml"/> 
    <import resource="classpath:META-INF/cxf/cxf-servlet.xml"/> 

	<bean id="ccInfoServiceImpl" class="ch.bedag.a11.ccinfo.business.service.impl.CCInfoWSImpl">
	</bean>
	
	<jaxws:endpoint id="ccInfoServiceEndpoint" implementor="#ccInfoServiceImpl" address="/ccinfo">
		<jaxws:features>
           <bean class="org.apache.cxf.feature.LoggingFeature"/>
        </jaxws:features>	
	</jaxws:endpoint>
</beans>

Regards
Mirko


-----Urspr√ľngliche Nachricht-----
Von: Daniel Kulp [mailto:dkulp@apache.org] 
Gesendet: Mittwoch, 27. August 2008 21:34
An: users@cxf.apache.org
Cc: Sertic Mirko, Bedag
Betreff: Re: WSDL first results in javax.wsdl.WSDLException


Can you try with 2.1.2?    Also, try running the wsdlvalidator on the wsdl to 
make sure that's valid.

Thanks!
Dan



On Wednesday 27 August 2008 7:55:08 am Sertic Mirko, Bedag wrote:
> Hi
>
>
>
> I am new to CXF and want  to implement a WebService with CXF 2.1.1 and
> WSDL first. Code generations runs pretty smooth, but when I try to
> access the WebService with serice?wsdl to get the WSDL document, I am
> getting the following exception:
>
>
>
> javax.wsdl.WSDLException: WSDLException: faultCode=OTHER_ERROR: Can't
> find prefix for ... Namespace prefixes must be set on the Definition
> object using the addNamespace(...) method.
>
>
>
> And ideas?
>
>
>
> Thanks a lot
>
> Mirko



-- 
Daniel Kulp
dkulp@apache.org
http://www.dankulp.com/blog

Mime
View raw message