cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schuhegger <Christian.Schuheg...@gmx.de>
Subject Status of simple frontend in CXF 2.1.1?
Date Wed, 06 Aug 2008 13:15:58 GMT

Hello,

I am trying to get a simple test running for 2 days now and originally I
thought I am doing something wrong. But now I've downloaded the CXF 2.1.1
source distribution and I built it myself. It builds fine with a
> mvn -DskipTests

If I change into the directory
 cxf/rt/frontend/simple
and I run the tests there I get the result:
Tests run: 15, Failures: 0, Errors: 12, Skipped: 0

Specifically I took the test:
cxf/rt/frontend/simple/src/test/java/org/apache/cxf/service/factory/RountripTest.java
and executed it alone in a separate clean eclipse workspace. In the form it
is it works fine, but If I add a last line:
        assertEquals("hello", client.echo("hello"));
I get a test failure. The root cause seems to be that the message is not
correctly deserialized on the receiving side. There I constantly get null
values as input to any methods that I tried to get running.

Here is the log output before the echo method is invoked with a null input:
-- snip start --
[INFO ][14:52:00.288][o.a.c.i.LoggingOutInterceptor                     ] :
Outbound Message
---------------------------
Encoding: UTF-8
Headers: {SOAPAction=[""]}
Messages: 
Payload: <soap:Envelope
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><ns1:echo
xmlns:ns1="http://repositories.impl.service.usermanagement.collectionmanager.p20080705.jces.jclusterjobs.sourceforge.net/"><arg0
xmlns="http://repositories.impl.service.usermanagement.collectionmanager.p20080705.jces.jclusterjobs.sourceforge.net/">hello</arg0></ns1:echo></soap:Body></soap:Envelope>
-- snip end --

The same behaviour I experienced with any tests I performed with the simple
server and the AegisDatabinding. All input parameters are set to null, even
if values are in the Payload.

Can anybody reproduce this problem? Or do I have some problem in my
environment?

Thanks,
-- 
Christian Schuhegger
http://www.el-chef.de/
-- 
View this message in context: http://www.nabble.com/Status-of-simple-frontend-in-CXF-2.1.1--tp18850960p18850960.html
Sent from the cxf-user mailing list archive at Nabble.com.


Mime
View raw message