cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Roberts <i.robe...@dcs.shef.ac.uk>
Subject Re: AW: AW: AW: Error after upgrading to jdk 1.6.0_06
Date Tue, 08 Jul 2008 20:13:00 GMT
Daniel Kulp wrote:
> 
> On Jul 7, 2008, at 1:52 PM, Marcus Redeker wrote:
> 
>> Dan,
>>
>> Thanks for the clarification. That makes sense.
>> But this means that the user must have a JDK if he uses the 
>> DynamicClient.
>> Is that somewhere in the docs?
> 
> I added it to the docs:
> http://cwiki.apache.org/confluence/display/CXF20DOC/Dynamic+Clients
> 
>> What about the eclipse compiler which is used by some jsp container?
> 
> A patch to enable that would be great.   :-)

http://svn.apache.org/viewvc/tomcat/trunk/java/org/apache/jasper/compiler/JDTCompiler.java

is the class that does the work in Tomcat.

Based on that I wrote 
http://gate.svn.sourceforge.net/viewvc/gate/gate/trunk/src/gate/util/compilers/Eclipse.java

which has a more useful API (just give it a Map with class names as keys 
and their Java source code as values), and it would probably not be too 
hard to adapt that for CXF.  The only problem is that GATE (and in 
particular my class above) is released under the LGPL, so I don't know 
what's the legal position on merging code based on it into an Apache 
project?  Someone else starting from the Tomcat codebase rather than 
mine wouldn't have that problem.

Ian

-- 
Ian Roberts               | Department of Computer Science
i.roberts@dcs.shef.ac.uk  | University of Sheffield, UK

Mime
View raw message