cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bdm <brent_mo...@byu.edu>
Subject Re: wsdl2java implicit header issues
Date Wed, 09 Jul 2008 22:33:44 GMT

Disregard my last message - programmer error :)  The classes work as
expected.

Brent
 

bdm wrote:
> 
> The workaround generates the correct interface and annotations, but when I
> use the classes I do not get the header attached to the outgoing message. 
> For now I'll add it by hand.  
> 
> 
> Brent
> 
> 
> bdm wrote:
>> 
>> JIRA issue is  	 https://issues.apache.org/jira/browse/CXF-1696
>> 
>> I'll try the workaround.
>> 
>> Thanks,
>> 
>> Brent
>> 
>> 
>> dkulp wrote:
>>> 
>>> 
>>> Definitely a bug.   It's looking in the main message first when trying  
>>> to resolve the soap:header "part" flag.
>>> 
>>> You can workaround it by changing the ARAuthenticate message to:
>>>    <message name="ARAuthenticate">
>>>       <part element="s:AuthenticationInfo" name="auth"/>
>>>    </message>
>>> 
>>> and the soap:header elements to:
>>> <soap:header message="s:ARAuthenticate" part="auth"  use="literal">
>>> 
>>> 
>>> Can you log a jira issue for this so it doesn't get lost?
>>> 
>>> Dan
>>> 
>>> 
>>> 
>>> 
>>> 
>>> ---
>>> Daniel Kulp
>>> dkulp@apache.org
>>> http://www.dankulp.com/blog
>>> 
>>> 
>>> 
>>> 
>>> 
>>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/wsdl2java-implicit-header-issues-tp18351228p18372343.html
Sent from the cxf-user mailing list archive at Nabble.com.


Mime
View raw message