cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: soap fault question
Date Tue, 22 Apr 2008 19:55:28 GMT

This should be fixed in the latest 2.0.6/2.1 snapshots.    If you could 
give it a quick test as a double check before I do final builds 
tomorrow, that would be GREAT.
http://people.apache.org/repo/m2-snapshot-repository/org/apache/cxf/apache-cxf/2.0.6-SNAPSHOT/
http://people.apache.org/repo/m2-snapshot-repository/org/apache/cxf/apache-cxf/2.1-SNAPSHOT/

Thanks!
Dan


On Tuesday 22 April 2008, sadhu wrote:
> David CastaƱeda wrote:
> > Hi, I'm still fighting with fault generation... can anybody give me
> > a pointer where to get some examples or some information about this?
> >
> > in a service that I'm exposing, I'm trying to do
> >
> >         SoapFault fault = new SoapFault(message,
> > SoapFault.FAULT_CODE_CLIENT);
> >         throw fault;
> >
> > but it always end in ...
> >
> > <soap:Envelope
> > xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"> <soap:Body>
> >       <soap:Fault>
> >          <faultcode>soap:Server</faultcode>
> >          <faultstring>Message is OK</faultstring>
> >       </soap:Fault>
> >    </soap:Body>
> > </soap:Envelope>
> >
> > I'm expecting to produce a Client Fault but soap:Server is returned.
> >
> > I'm using a jaxws:endpoint
> >
> >
> > --
> > David CastaƱeda R.
>
> hey David .
> Did u get the solution...
> please if so post me the details also..
> i'm also struggling to solve this issues..
>
> Thanks in advance
>
>
> Regards
>
> Suzane



-- 
J. Daniel Kulp
Principal Engineer, IONA
dkulp@apache.org
http://www.dankulp.com/blog

Mime
View raw message