cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roshan A. Punnoose" <rpunno...@proteus-technologies.com>
Subject RE: Jaxb databinding issue
Date Thu, 15 Nov 2007 20:05:34 GMT
I just tried that, and no luck. I also tried to add the jaxb.index file
to the package but that didn't seem to work either. Man...

Roshan

-----Original Message-----
From: Benson Margulies [mailto:bim2007@basistech.com] 
Sent: Thursday, November 15, 2007 3:00 PM
To: cxf-user@incubator.apache.org
Subject: RE: Jaxb databinding issue

Yes. I fixed a later issue that had to do with array types and which
could produce a message like that. 

> -----Original Message-----
> From: Roshan A. Punnoose [mailto:rpunnoose@proteus-technologies.com] 
> Sent: Thursday, November 15, 2007 3:02 PM
> To: cxf-user@incubator.apache.org
> Subject: RE: Jaxb databinding issue
> 
> I believe I'm running 2.0.2-incubator. Should I upgrade?
> 
> -----Original Message-----
> From: Benson Margulies [mailto:bim2007@basistech.com]
> Sent: Thursday, November 15, 2007 2:56 PM
> To: cxf-user@incubator.apache.org
> Subject: RE: Jaxb databinding issue
> 
> This looks like a cousin of a more recent issue involving 
> byte[]. Are you running 2.0.3?
> 
> > -----Original Message-----
> > From: Roshan A. Punnoose [mailto:rpunnoose@proteus-technologies.com]
> > Sent: Thursday, November 15, 2007 2:58 PM
> > To: cxf-user@incubator.apache.org
> > Subject: Jaxb databinding issue
> > 
> > I am having the same problems as described in: CXF-340 :
> > https://issues.apache.org/jira/browse/CXF-340
> > 
> > But I can't seem to get the fix working. My spring file currently 
> > looks like this:
> > 
> > <jaxws:endpoint id="service" address="/service"
> > 		implementor="#serviceimpl">
> > 		<jaxws:binding>
> > 			<soap:soapBinding mtomEnabled="true"
> > version="1.2"/>
> > 		</jaxws:binding>
> > 		<jaxws:properties>
> > 			<entry key="jaxb.additionalContextClasses">
> > 				<bean
> > class="groundstation.xqueryservice.utils.ClassArrayFactoryBean">
> > 					<property name="classNames">
> > 						<list>
> > 							<value>station.
> > service.MyClass</value>
> > 						</list>
> > 					</property>
> > 				</bean>
> > 			</entry>
> > 		</jaxws:properties>
> > 	</jaxws:endpoint>
> > 
> > But this hasn't fixed the issue. I still keep getting: Marshalling
> > Error: [Lstation.service.MyClass; is not known to this context
> > 
> > Any ideas?
> > 
> 

Mime
View raw message