cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benson Margulies" <bim2...@basistech.com>
Subject RE: Missing namespace prefix on arg0 ?
Date Mon, 26 Nov 2007 21:17:49 GMT
Look at the schema for elementFormDefault and/or specific form=
modifiers. Code first? RPC or Doc? 

> -----Original Message-----
> From: Kaleb Walton [mailto:kdwalton@us.ibm.com] 
> Sent: Monday, November 26, 2007 2:11 PM
> To: cxf-user@incubator.apache.org
> Subject: Missing namespace prefix on arg0 ?
> 
> 
> 
> This may be due to my lack of expertise with XML / WSDLs in 
> general but I am confused as to why the <arg0> tag below does 
> not include the ns1: prefix as the rest of the tags do. If I 
> add the ns1: prefix to <arg0> (to make it
> <ns1:arg0>) CXF does not digest the request properly. Is 
> there any way to apply a namespace to the arg tag or should I 
> not be concerned with it?
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <SOAP-ENV:Envelope SOAP-ENV:encodingStyle="
> http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENC="
> http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsi="
> http://www.w3.org/1999/XMLSchema-instance" xmlns:SOAP-ENV="
> http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd3="
> http://www.w3.org/2001/XMLSchema" xmlns:xsd="
> http://www.w3.org/1999/XMLSchema">
> <SOAP-ENV:Body>
> <ns1:findAll xmlns:ns1="http://services.iss.net/v1" 
> SOAP-ENC:root="1"> <arg0> <ns1:sort 
> xsi:type="xsd:string">startTime.ASC</ns1:sort>
> <ns1:startDate
> xsi:type="xsd3:dateTime">2006-11-26T11:56:11Z</ns1:startDate>
> <ns1:endDate 
> xsi:type="xsd3:dateTime">2007-11-26T11:56:11Z</ns1:endDate>
> <ns1:populate xsi:type="xsd:string">true</ns1:populate>
> <ns1:start xsi:type="xsd:int">0</ns1:start> <ns1:limit 
> xsi:type="xsd:int">100</ns1:limit>
> <ns1:customerId xsi:type="xsd:string">CID001696</ns1:customerId>
> </arg0>
> </ns1:findAll>
> </SOAP-ENV:Body>
> </SOAP-ENV:Envelope>
> 
> Regards,
> Kaleb
> 

Mime
View raw message