cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benson Margulies" <bim2...@basistech.com>
Subject RE: Diagnosis of stupid JAXB/JAXWS errors
Date Mon, 26 Nov 2007 12:53:13 GMT
No, I'd say that they are different. This person is getting a web
message sent out with a missing namespace. In my case, the response that
goes out is completely empty. 

> -----Original Message-----
> From: Jim Ma [mailto:ema@iona.com] 
> Sent: Sunday, November 25, 2007 9:27 PM
> To: cxf-user@incubator.apache.org
> Subject: Re: Diagnosis of stupid JAXB/JAXWS errors
> 
> Hi Benson ,
> 
> Is this issue same as https://issues.apache.org/jira/browse/CXF-1226?
> 
> Regards
> 
> Jim
> 
> Benson Margulies wrote:
> > Consider the following pile of snails. Now, I realize, I don't need 
> > them in CXF, but I had coded them to test something. 
> Except, that, I'd 
> > neglected to code the @WebResult at all, so while I had a wrapper, 
> > there was no way for the code to know the element to use 
> for the response.
> >
> > It didn't work, of course. It also didn't diagnose in the 
> log. Should 
> > this sort of thing produce some whining?
> >
> >    @RequestWrapper(className =
> > 
> "org.apache.cxf.javascript.fortest.BasicTypeFunctionReturnStri
> ngWrapper"
> > )
> >     @ResponseWrapper(className =
> > "org.apache.cxf.javascript.fortest.StringWrapper")
> >     @WebResult(name = "returnValue", targetNamespace =
> > "uri:org.apache.cxf.javascript.testns")
> >
> >   
> 

Mime
View raw message