cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benson Margulies" <bim2...@basistech.com>
Subject RE: WSDL not recognized by vs net
Date Wed, 10 Oct 2007 12:20:01 GMT
What version of Visual Studio? With 2005, I don't see a difference based
on part names. There is a web page out there that claims that wsdl.exe
does different things depending on the part name, but 2005 works just
the same (wrapping parameters in an object) either way.

> -----Original Message-----
> From: William Leung [mailto:lwr@21cn.com]
> Sent: Wednesday, October 10, 2007 8:01 AM
> To: cxf-user@incubator.apache.org
> Subject: Re: WSDL not recognized by vs net
> 
> 
> Very annoyance :(((
> 
> After quite a few trys, I finally make HelloWorld worked with vs net
> (2005).
> 
> just change these line in WDSL:  ( wrapped DOC/LIT  )
> 
>   <wsdl:message name="sayHiResponse">
>     <wsdl:part element="tns:sayHiResponse" name="result">
>     </wsdl:part>
>   </wsdl:message>
> 
> after change the name from "result" to "parameters"
> vs net recognized the WSDL, and "string hello.sayHi(string)" is
finally
> available.
> 
> Anyone could tell me why?
> 
> 
> 
> William Leung wrote:
> >
> > I am testing CXF and sadlly found that our method parameters and
returns
> > are not recognized in vs net.
> >
> > VS NET recongnized the sayHi function as
> > --- sayHi ( sayHi As sayHi ) As sayHiResponse
> > it should be
> > --- sayHi ( arg0 As string) as string
> >
> >
> > When I change the wsdl manually from
> >
> >       <xsd:element name="sayHi" type="tns:sayHi"/>
> >       <xsd:complexType name="sayHi">
> >         <xsd:sequence>
> >           <xsd:element minOccurs="0" name="arg0" type="xsd:string"/>
> >         </xsd:sequence>
> >       </xsd:complexType>
> >
> > to
> >
> >       <xsd:element>
> >         <xsd:complexType>
> >           <xsd:sequence>
> >             <xsd:element minOccurs="0" name="arg0"
type="xsd:string"/>
> >           </xsd:sequence>
> >         </xsd:complexType>
> >       </xsd:element>
> >
> > It worked, but I have no idea how could I make this changes without
> switch
> > to "wsdl first" (I dont want to, I have just too many methods to
export)
> >
> > Any help will be very appreciated
> >
> 
> --
> View this message in context:
http://www.nabble.com/WSDL-not-recognized-
> by-vs-net-tf4599448.html#a13134355
> Sent from the cxf-user mailing list archive at Nabble.com.


Mime
View raw message