cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mustafa Egilmezbilek" <egilmezbi...@gmail.com>
Subject Re: WebServiceContext is null
Date Fri, 28 Sep 2007 21:42:52 GMT
Hi,

I am using <tx:annotation-driven/> in my spring.xml .
What's the workaround for this case ?

Thanks,

Karakoyun


On 9/28/07, Willem Jiang <ning.jiang@iona.com> wrote:
>
> Hi ,
>
> How do you set up your endpoint implementor?
>
> I  know there is an issue that if your implementor is came from a Spring
> bean which is enhanced by Spirng AOP will not get any WebServiceContext
> resource injected.
>
> You can find the detail information about the JIRA here [1]
> [1]https://issues.apache.org/jira/browse/CXF-1074
>
> Willem.
>
>
> Mustafa Egilmezbilek wrote:
> > Hi,
> >
> > I am trying to access WebServiceContext to be able use HttpSession as
> > described in: http://cwiki.apache.org/CXF20DOC/servlet-transport.html,
> but I
> > keep getting null. What might be the reason ?
> >
> >
> > @Resource
> >
> > *public* WebServiceContext wsContext;
> >  protected HttpSession getHttpSession() {
> >   MessageContext mc = *wsContext*.getMessageContext();
> >         HttpSession session = ((javax.servlet.http.HttpServletRequest
> > )mc.get(MessageContext.SERVLET_REQUEST)).getSession();
> >         return session;
> >  }
> >
> >
> >
> > Thanks,
> >
> > Karakoyun
> >
> >
>



-- 
Mustafa Egilmezbilek

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message