cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yeroc <cpli...@gmail.com>
Subject JAX-WS Handlers conflict with JBoss client?
Date Fri, 21 Sep 2007 22:44:37 GMT

All...

I'm trying to get handlers working on my JAX-WS service without success.  I
based my work off of the logging example that ships with CXF v2.0.1.  My
handler is registering fine and get called but I get the following errors
showing up in my Tomcat logs as soon as I call
SOAPMessageContext.getMessage():

2007-09-21 16:09:01,832 DEBUG [http-8081-Processor23]
javax.xml.soap.MessageFactory.newInstance(MessageFactory.java:101): Cannot
load factory: org.jboss.axis.soap.MessageFactoryImpl
2007-09-21 16:09:01,862 DEBUG [http-8081-Processor23]
javax.xml.soap.MessageFactory.newInstance(MessageFactory.java:101): Cannot
load factory: org.jboss.axis.soap.MessageFactoryImpl

Unfortunately, it doesn't print out a stack trace so I can't really find the
source of the problem.  I did notice though that the factory it's using is
org.jboss.axis.soap.MessageFactoryImpl rather than a CXF factory which is
likely the root of the problem.  My service accesses a remote JBoss server
so it has the jboss-client.jar included which contains this class.

Has anyone else run into this problem?  Does anyone know of a solution?

Thanks,
Corey
-- 
View this message in context: http://www.nabble.com/JAX-WS-Handlers-conflict-with-JBoss-client--tf4499015.html#a12831143
Sent from the cxf-user mailing list archive at Nabble.com.


Mime
View raw message