cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Kallstrom" <dave.kallst...@gmail.com>
Subject Re: Aegis and mtom
Date Wed, 08 Aug 2007 15:50:30 GMT
Please ignore this post for now. Looks like there is a previous post
involving this same issue

On 8/8/07, Dave Kallstrom <dave.kallstrom@gmail.com> wrote:
>
> If I have mtom-enabled set to true and I am using aegis bindings why is my
> wsdl complex type being generated like this?
>
> <element name="imageData" type="base64Binary"/>
>
> Instead of like this
>
> <element name="imageData" type="base64Binary"
> xmime:expectedContentType="application/octet-stream"/>
>
> I think have my aegis config file correct
>
> <property name="imageData"  nillable="false"
> expectedContentTypes="application/octet-stream"
>
> My imageData is one of type     private javax.activation.DataHandlerimageData;
>
> Hers is my cxf.xml file
>
> <jaxws:endpoint id="CollectiveServices" implementor="#serviceBean"
> address="/CollectiveServices" >
>         <jaxws:serviceFactory>
>             <bean class="
> org.apache.cxf.jaxws.support.JaxWsServiceFactoryBean">
>                 <property name="dataBinding" ref="aegisBinding"/>
>                 <property name="serviceConfigurations">
>                     <list>
>                         <ref bean="jaxConfig"/>
>                         <ref bean="aegisConfig"/>
>                         <ref bean="defaultConfig"/>
>                     </list>
>                 </property>
>             </bean>
>         </jaxws:serviceFactory>
>         <jaxws:properties>
>             <entry key="mtom-enabled" value="true"/>
>         </jaxws:properties>
>         <jaxws:features>
>             <bean class="org.apache.cxf.feature.LoggingFeature "/>
>         </jaxws:features>
>     </jaxws:endpoint>
> Perhaps I should just switch to jaxb?
> Dave Kallstrom




-- 
Dave Kallstrom

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message