cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven E. Harris" <...@panix.com>
Subject Re: Figuring out why an endpoint isn't reachable through a Servlet
Date Sun, 06 May 2007 16:57:35 GMT
Dan Diephouse <dan@envoisolutions.com> writes:

> As mentioned in that issue it seems this is fixed in JAXB 2.1.3.

Is the general public supposed to be using this version of JAXB? If
so, and JAXB is bundled with the JRE, are we supposed to wait until
the next JRE release to get a version of JAXB that actually works?

I've done a lot of Web searching for some mention of this problem, and
the only hits are the various copies of the XFire JIRA issue. That
leaves me to wonder why no one else is seeing this problem -- and
scrambling to do something about it.

> I saw that you were getting some linkage error when you tried
> this. If you're running on Java 6 this is probably because JAXB 2.0
> is bundled with the JVM, which causes a conflict.

Yes, I'm running Java 6 (1.6.0_01).

> If not, it would be great if you could post the error here or in a
> JIRA issue so we could attempt to fix it. Thanks,

I apologize for being vague when describing that error. I had seen it
hours before writing, forced to have given up that pursuit due to
other assignments at work. Most of the time was wasted trying to
figure out how to convince Maven not to include the versions of the
JAXB JARs being pulled in by some of CXF's transitive dependencies┬╣. I
only succeed in being able to /add/ more JAXB JARs, not prevent the
designated JARs from being included.

I'll try to set up another test this coming week to get the actual
error message emitted by Tomcat when I tried to load my CXF Web
application using updated JAXB JARs.


Footnotes: 
┬╣ Does anyone know of a way to trace the root cause of a dependency in
  Maven? That is, find which artifact cites the dependency directly?

-- 
Steven E. Harris

Mime
View raw message