cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <daniel.k...@iona.com>
Subject Re: The next milestone release
Date Tue, 27 Feb 2007 13:57:44 GMT
On Tuesday 27 February 2007 06:52, Srepfler Srgjan wrote:
> Daniel Kulp wrote:
> > Anyway, stick with 1.5 for CXF for now.
> >
> Are we to use JDK 1.5 only for building or is it obligatory also as a
> runtime?

Honestly, I don't know right now as I kind of gave up on using it.   For 
building and for running our unit tests, 1.5 is a must.

For runtime, you probably can get away with 1.6, but you may need to copy 
some jars over to your jre/lib/endorsed dir.    Most likely, the JAXB 
jars, the JAXWS jars, and the stax-api jar would need to be copied there.   
The ones we use are newer than the ones in Java 6 so you need to make sure 
you grab the newer ones.   If you give it a try, please let me know.   I'd 
love to know how it works out.

Actually, if you copy those jars to the endorsed dir, you MIGHT be able to 
even build/run the tests.   Not sure.   I haven't tried it.


-- 
J. Daniel Kulp
Principal Engineer
IONA
P: 781-902-8727    C: 508-380-7194
daniel.kulp@iona.com
http://www.dankulp.com/blog

Mime
View raw message