cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andriy Redko (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CXF-7510) SSE integration in CDI abruptly fails with no indication why
Date Sun, 08 Oct 2017 23:17:00 GMT

    [ https://issues.apache.org/jira/browse/CXF-7510?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16196365#comment-16196365
] 

Andriy Redko edited comment on CXF-7510 at 10/8/17 11:16 PM:
-------------------------------------------------------------

Hey guys,

Would appreciate your help / hints here please. So I started to look into this issue, there
are basically two observations I have at the moment:
 - the automatic discovery of Features (SseFeature f.e.) in CDI works, no issue here (assuming
beans.xml has no package exclusions)
 - the sample project we have provided as part of distribution references older Jetty 9.3.5.v20151012,
messing dependencies up with Jetty 9.4.6.v20170531 

But I cannot reproduce imminent issue with initialization. Would you mind guys to attach the
sample project to this ticket so we could pin-point the exact problem?
Thanks.

Best Regards,
    Andriy Redko


was (Author: reta):
Hey guys,

Would appreciate your help / hints here please. So I started to look into this issue, there
are basically two observations I have at the moment:
 - the automatic discovery of Features (SseFeature f.e.) in CDI works, no issue here (assuming
beans.xml has no package exclusions)
 - the sample project we have provided as part of distribution references older Jetty 9.3.5.v20151012,
messing dependencies up with Jetty 9.4.6.v20170531 

Would you mind guys to attach the sample project to this ticket so we could pin-point the
exact problem?
Thanks.

Best Regards,
    Andriy Redko

> SSE integration in CDI abruptly fails with no indication why
> ------------------------------------------------------------
>
>                 Key: CXF-7510
>                 URL: https://issues.apache.org/jira/browse/CXF-7510
>             Project: CXF
>          Issue Type: Bug
>            Reporter: John D. Ament
>            Assignee: Andriy Redko
>
> https://lists.apache.org/thread.html/10d99c0d013a3d23361a3898171e7bd2b311a509349433db3b6cacaa@%3Cusers.cxf.apache.org%3E
has more details
> Intermittently, when bootstrapping CXF + CDI, the integration for SSE will fail.  When
it fails, there's no log messages indicating the issue, however attempts to invoke any rest
endpoint will give a warning like:
> {code}
> Sep 17, 2017 7:50:33 PM org.apache.cxf.transport.servlet.ServletController
> invoke
> WARNING: Can't find the request for http://my-hostname:4403/rest's Observer
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message