cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "na sam (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-7485) Reverse proxy url is not reflected in Swagger UI response
Date Tue, 05 Sep 2017 09:04:00 GMT

    [ https://issues.apache.org/jira/browse/CXF-7485?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16153310#comment-16153310
] 

na sam  commented on CXF-7485:
------------------------------

Tested with Swagger2Feature.usePathBasedConfig = true and worked great.

[~sergey_beryozkin], thanks for your effort to fix this issue. 

Could you please let me know when this fix would go into release.

Thanks again.



> Reverse proxy url is not reflected in Swagger UI response
> ---------------------------------------------------------
>
>                 Key: CXF-7485
>                 URL: https://issues.apache.org/jira/browse/CXF-7485
>             Project: CXF
>          Issue Type: Bug
>          Components: Documentation
>    Affects Versions: 3.1.12
>            Reporter: na sam 
>            Assignee: Sergey Beryozkin
>             Fix For: 3.1.13, 3.2.0
>
>
> I am using Swagger2Feature to generate the swagger out of my REST service classes. 
> All the url's that is being generated are based on deployed server's web path. Its working
directly in my server. But If the request comes via reverse proxy, then in my  swagger ui
response I am seeing still same my local server's webpath instead of one coming via reverse
proxy.
> Need a way to support reverse proxy web path.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message