cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Schlüssel (JIRA) <j...@apache.org>
Subject [jira] [Created] (CXF-7490) JAXRS REST server causes long bundle starting time in OSGi blueprint
Date Wed, 30 Aug 2017 08:35:01 GMT
Max Schlüssel created CXF-7490:
----------------------------------

             Summary: JAXRS REST server causes long bundle starting time in OSGi blueprint
                 Key: CXF-7490
                 URL: https://issues.apache.org/jira/browse/CXF-7490
             Project: CXF
          Issue Type: Bug
          Components: JAX-RS, OSGi
    Affects Versions: 3.1.8
         Environment: Camel 2.18.1, Aries Blueprint 1.7.1, Karaf 4.0.9, Debian 3.16.39-1
            Reporter: Max Schlüssel
            Priority: Minor


I've encountered a weird problem when creating a REST server in blueprint.

The bundle has nothing but a simple server that contains one service bean, configured like
this:
{code:xml}
<jaxrs:server address="/test" id="testRestService">
	<jaxrs:serviceBeans>
		<ref component-id="defaultTestRestService" />
	</jaxrs:serviceBeans>
</jaxrs:server>

<bean id="defaultTestRestService" class="de.maxdev.resttest.DefaultTestRestService" />
{code}

When I deploy this bundle on Karaf in a Linux environment, the bundle remains in the "Starting"
state for about 120 seconds. On Windows however, it starts in about 3 seconds. When not taking
care of bundle deployment order, this will block all the other bundles, too.

Is this a bug or a misconfiguration? Maybe this is caused some lower-level socket issue?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message