cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Buckett (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-7483) JAXRSServerFactoryBeanDefinitionParser doesn't log autowire failures
Date Fri, 25 Aug 2017 09:20:00 GMT

    [ https://issues.apache.org/jira/browse/CXF-7483?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16141409#comment-16141409
] 

Matthew Buckett commented on CXF-7483:
--------------------------------------

Thanks for the helpful reply, I think you're right on the money about not changing for the
3.2 release. I've created CXF-7486 to track the issue.

> JAXRSServerFactoryBeanDefinitionParser doesn't log autowire failures
> --------------------------------------------------------------------
>
>                 Key: CXF-7483
>                 URL: https://issues.apache.org/jira/browse/CXF-7483
>             Project: CXF
>          Issue Type: Bug
>          Components: JAX-RS
>    Affects Versions: 3.1.7
>            Reporter: Matthew Buckett
>            Assignee: Sergey Beryozkin
>             Fix For: 3.0.15, 3.1.13, 3.2.0
>
>
> I was using the scanning through spring XML config:
> {code:xml}
> <beans
>           xmlns:jaxrs="http://cxf.apache.org/jaxrs">
> <!-- snipped -->
> <jaxrs:server address="/rest" basePackages="org.example.rest">
> </jaxrs:server>
> <!-- snipped -->
> </beans>
> {code}
> and my autowiring was failing and I was ending up with a un-autowired bean instead. Debugging
this was tricky and it was because {{org.apache.cxf.jaxrs.spring.JAXRSServerFactoryBeanDefinitionParser#createBeansFromDiscoveredClasses}}
doesn't log anything when autowiring fails, it would be helpful if it either threw the exception
showing where the problem was or logged it and said it was creating an non-autowired bean.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message