cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emile Fugulin (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CXF-7451) Outdated vulnerable dependency in cxf-rt-transports-http-jetty
Date Thu, 20 Jul 2017 13:24:00 GMT

    [ https://issues.apache.org/jira/browse/CXF-7451?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16094666#comment-16094666
] 

Emile Fugulin edited comment on CXF-7451 at 7/20/17 1:23 PM:
-------------------------------------------------------------

Yea I guess it should be fixed, maybe its a false positive from Snyk.
The article also says: "GDS also found that beta releases and later (including the beta releases
of 9.3.x) are vulnerable."


was (Author: sytten):
Yea I guess it should be fixed, maybe its a false positive from Snyk.
I will contact them.

> Outdated vulnerable dependency in cxf-rt-transports-http-jetty
> --------------------------------------------------------------
>
>                 Key: CXF-7451
>                 URL: https://issues.apache.org/jira/browse/CXF-7451
>             Project: CXF
>          Issue Type: Improvement
>            Reporter: Emile Fugulin
>
> Hi,
> We use cxf-rt-transports-http-jetty in our project, but the latest version still depends
on Jetty 9.2.21.
> The problem is that jetty-http 9.2 is vulnerable: 
> https://blog.gdssecurity.com/labs/2015/2/25/jetleak-vulnerability-remote-leakage-of-shared-buffers-in-je.html
> You can also look at https://snyk.io/vuln/SNYK-JAVA-ORGECLIPSEJETTY-30090 for more information.
> Thanks!



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message