cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Poth (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CXF-7437) OSGI 'Uses constraint violation' when deploying org.apache.cxf.cxf-rt-rs-service-description-swagger
Date Tue, 04 Jul 2017 08:10:00 GMT
John Poth created CXF-7437:
------------------------------

             Summary: OSGI 'Uses constraint violation' when deploying org.apache.cxf.cxf-rt-rs-service-description-swagger
                 Key: CXF-7437
                 URL: https://issues.apache.org/jira/browse/CXF-7437
             Project: CXF
          Issue Type: Bug
          Components: JAX-RS
            Reporter: John Poth


When installing feature cxf-rs-description-swagger2 on Karaf 4.2.0-SNAPSHOT I get the following
error:

{code}
Error executing command: Error restarting bundles:
	Uses constraint violation. Unable to resolve resource org.apache.cxf.cxf-rt-rs-service-description-swagger
[org.apache.cxf.cxf-rt-rs-service-description-swagger [217](R 217.0)] because it is exposed
to package 'javax.annotation' from resources javax.annotation-api [javax.annotation-api [45](R
45.0)] and org.apache.felix.framework [org.apache.felix.framework [0](R 0)] via two dependency
chains.

Chain 1:
  org.apache.cxf.cxf-rt-rs-service-description-swagger [org.apache.cxf.cxf-rt-rs-service-description-swagger
[217](R 217.0)]
    import: (&(osgi.wiring.package=javax.annotation)(version>=1.3.0)(!(version>=2.0.0)))
     |
    export: osgi.wiring.package: javax.annotation
  javax.annotation-api [javax.annotation-api [45](R 45.0)]

Chain 2:
  org.apache.cxf.cxf-rt-rs-service-description-swagger [org.apache.cxf.cxf-rt-rs-service-description-swagger
[217](R 217.0)]
    import: (&(osgi.wiring.package=io.swagger.converter)(version>=1.5.0)(!(version>=2.0.0)))
     |
    export: osgi.wiring.package=io.swagger.converter; uses:=com.google.common.collect
  io.swagger.core [io.swagger.core [212](R 212.0)]
    import: (&(osgi.wiring.package=com.google.common.collect)(version>=18.0.0)(!(version>=19.0.0)))
     |
    export: osgi.wiring.package=com.google.common.collect; uses:=javax.annotation
  com.google.guava [com.google.guava [38](R 38.0)]
    import: (osgi.wiring.package=javax.annotation)
     |
    export: osgi.wiring.package: javax.annotation
  org.apache.felix.framework [org.apache.felix.framework [0](R 0)] Unresolved requirements:
[[org.apache.cxf.cxf-rt-rs-service-description-swagger [217](R 217.0)] osgi.wiring.package;
(&(osgi.wiring.package=io.swagger.converter)(version>=1.5.0)(!(version>=2.0.0)))]
{code}

I can provide a fix



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message