cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Beryozkin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-7010) Swagger2Feature can not auto-link to SwaggerUi in OSGI
Date Sun, 02 Apr 2017 17:56:42 GMT

    [ https://issues.apache.org/jira/browse/CXF-7010?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15952791#comment-15952791
] 

Sergey Beryozkin commented on CXF-7010:
---------------------------------------

Hi Andrei

Can you please experiment with setting a 2nd parameter to true:
https://github.com/apache/cxf/blob/master/rt/transports/http/src/main/java/org/apache/cxf/transport/http/osgi/HttpServiceTrackerCust.java#L65

I hope this is where the real fix should go in

We need to also show the swagger links, and the high chance is either WADL or Swagger link
will be non-operational if we just show both of them :-) 

Thanks Sergey

> Swagger2Feature can not auto-link to SwaggerUi in OSGI
> ------------------------------------------------------
>
>                 Key: CXF-7010
>                 URL: https://issues.apache.org/jira/browse/CXF-7010
>             Project: CXF
>          Issue Type: Bug
>          Components: JAX-RS
>    Affects Versions: 3.1.7
>            Reporter: Sergey Beryozkin
>            Assignee: Sergey Beryozkin
>             Fix For: 3.1.8, 3.2.0
>
>




--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message