cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CXF-6040) need use servicemix wrapped opensaml 2.6.1_2
Date Wed, 22 Mar 2017 18:12:41 GMT

     [ https://issues.apache.org/jira/browse/CXF-6040?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Kulp resolved CXF-6040.
------------------------------
       Resolution: Fixed
         Assignee: Daniel Kulp  (was: Freeman Fang)
    Fix Version/s: 3.0.0

We moved to OpenSaml 3 a while ago which has fixed this.

> need use servicemix wrapped opensaml 2.6.1_2 
> ---------------------------------------------
>
>                 Key: CXF-6040
>                 URL: https://issues.apache.org/jira/browse/CXF-6040
>             Project: CXF
>          Issue Type: Bug
>            Reporter: Freeman Fang
>            Assignee: Daniel Kulp
>             Fix For: 3.0.0
>
>
> as servicemix wrapped opensaml 2.6.1_1 pull in wrong xerces dependency like(because build
against the Shibboleth repo but not the maven central repo)[1]
> <dependency>
>     <groupId>org.apache.xerces</groupId>
>     <artifactId>xercesImpl</artifactId>
>     <version>2.10.0</version>
>     <scope>runtime</scope>
> </dependency>
> This wrong groupId can cause lots of problems as Dan explained in CXF-5565



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message