cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Concombre Masqué (JIRA) <j...@apache.org>
Subject [jira] [Updated] (CXF-7204) CXF 3.1.9 does not support Spring 3.2, enforces Spring 4.1
Date Wed, 04 Jan 2017 10:05:58 GMT

     [ https://issues.apache.org/jira/browse/CXF-7204?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Concombre Masqué updated CXF-7204:
----------------------------------
    Environment: Java 8, OSGi (Karaf 3.0.8, Spring 3.2)  (was: Java 8)

> CXF 3.1.9 does not support Spring 3.2, enforces Spring 4.1
> ----------------------------------------------------------
>
>                 Key: CXF-7204
>                 URL: https://issues.apache.org/jira/browse/CXF-7204
>             Project: CXF
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 3.1.9
>         Environment: Java 8, OSGi (Karaf 3.0.8, Spring 3.2)
>            Reporter: Concombre Masqué
>
> With CXF 3.1.8:
> File META-INF/cxf/cxf.xml does not specify an explicit Spring version. Spring 3.2 and
CXF 3.1.8 work well together.
> With CXF 3.1.9:
> File META-INF/cxf/cxf.xml uses Spring 4.1 schema. Cannot use Spring 3.2 anymore.
> CXF Migration Guide does not indicate such major change for version 3.1 (version 3.0
is said to be compatible with Spring 3.2: http://cxf.apache.org/docs/30-migration-guide.html)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message