cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Beryozkin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-7010) Swagger2Feature can not auto-link to SwaggerUi in OSGI
Date Mon, 15 Aug 2016 20:39:20 GMT

    [ https://issues.apache.org/jira/browse/CXF-7010?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15421634#comment-15421634
] 

Sergey Beryozkin commented on CXF-7010:
---------------------------------------

Hi Ɓukasz, 
Hmm, I wonder if a bus visible to ServletController is different to the one which Swagger2Feature
uses to set a swaggerUiAvailability flag. Should be the same but may be it is not the case
in your deployment, can you please 
check bus instances at
https://github.com/apache/cxf/blob/3.1.x-fixes/rt/transports/http/src/main/java/org/apache/cxf/transport/servlet/servicelist/FormattedServiceListWriter.java#L176
and  
https://github.com/apache/cxf/blob/3.1.x-fixes/rt/rs/description-swagger/src/main/java/org/apache/cxf/jaxrs/swagger/Swagger2Feature.java#L99
thanks, Sergey

> Swagger2Feature can not auto-link to SwaggerUi in OSGI
> ------------------------------------------------------
>
>                 Key: CXF-7010
>                 URL: https://issues.apache.org/jira/browse/CXF-7010
>             Project: CXF
>          Issue Type: Bug
>          Components: JAX-RS
>    Affects Versions: 3.1.7
>            Reporter: Sergey Beryozkin
>             Fix For: 3.2.0, 3.1.8
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message