cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Łukasz Dywicki (JIRA) <j...@apache.org>
Subject [jira] [Commented] (CXF-6524) Swagger 2 feature doesn't work with blueprint endpoints
Date Fri, 12 Aug 2016 09:53:20 GMT

    [ https://issues.apache.org/jira/browse/CXF-6524?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15418605#comment-15418605
] 

Łukasz Dywicki commented on CXF-6524:
-------------------------------------

Sorry for one year delay :-) - yes I added feature at bus level, not endpoint. With endpoint
swagger feature works fine.

> Swagger 2 feature doesn't work with blueprint endpoints
> -------------------------------------------------------
>
>                 Key: CXF-6524
>                 URL: https://issues.apache.org/jira/browse/CXF-6524
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 3.0.6
>            Reporter: Łukasz Dywicki
>            Assignee: Akitoshi Yoshida
>             Fix For: 3.1.3, 3.0.7
>
>
> Swagger2 feature is not working with standard blueprint endpoints. Attaching of feature
fails cause {{org.apache.cxf.jaxrs.swagger.AbstractSwaggerFeature#initialize(Server, Bus)}}
method never gets called in this environment. What is being called is {{initializeProvider(InterceptorProvider,
Bus)}} method which is not overriden by AbstractSwaggerFeature. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message