cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niten Aggarwal (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-6952) Swagger2Featue not scanning CXF resources
Date Tue, 05 Jul 2016 21:47:11 GMT

    [ https://issues.apache.org/jira/browse/CXF-6952?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15363318#comment-15363318
] 

Niten Aggarwal commented on CXF-6952:
-------------------------------------

Hi Aki,

I am still not able to deploy 3.2.SNAPSHOT because snapshot repository doesn't find artifact
i.e. cxf-rt-rs-service-description-swagger2. Instead it has cxf-rt-rs-service-description-swagger.
I am looking https://repository.apache.org/content/groups/snapshots-group/.

<feature name="cxf-rs-description-swagger2" version="3.2.0-SNAPSHOT" resolver="(obr)">
        <feature version="3.2.0-SNAPSHOT">cxf-jaxrs</feature>
        <bundle start-level="40">mvn:org.apache.cxf/cxf-rt-rs-service-description-swagger2/3.2.0-SNAPSHOT</bundle>

When I try deployment for cxf 3.1.5, it fails as it's not able to find artifact for jax_rs_description_swagger2_osgi/3.1.5.

I am sure my mvn repositories not configured properly at Mvn(settings.xml) or Karaf (org.ops4j.pax.url.mvn.cfg)
level. Please let me know mvn repositories to be configured to load these artifacts.

Thanks
Nitin

> Swagger2Featue not scanning CXF resources
> -----------------------------------------
>
>                 Key: CXF-6952
>                 URL: https://issues.apache.org/jira/browse/CXF-6952
>             Project: CXF
>          Issue Type: Bug
>          Components: JAX-RS
>    Affects Versions: 3.1.3, 3.1.5
>         Environment: Windows
>            Reporter: Niten Aggarwal
>              Labels: features
>
> Swagger2Feature is not scanning end points configured in OSGI blueprint and always returning
default Swagger Json. 
> To reproduce issue, I deployed https://github.com/apache/cxf/tree/master/distribution/src/main/release/samples/jax_rs/description_swagger2_osgi
project as well into my Karaf runtime but no luck and same default Json is returned.
> https://issues.apache.org/jira/browse/CXF-6524
> https://issues.apache.org/jira/browse/CXF-6541
> Was following above bugs and it seems with versions 3.0.6, 3.1.2 this issue should be
resolved so I tried with cxf versions 3.1.2, 3.1.3 and 3.1.5 but no luck.
> Also the samples distribution which is using 3.2.0-SNAPSHOT, also returns default json.
> Default json which I am getting..
> {"swagger":"2.0","info":{"description":"The Application","version":"1.0.0","title":"Sample
REST Application","contact":{"name":"users@cxf.apache.org"},"license":{"name":"Apache 2.0
License","url":"http://www.apache.org/licenses/LICENSE-2.0.html"}},"basePath":"/cxf/swaggerSample"}
> Also sample Json doesn't recognize base path and always returned at http://localhost:8181/swaggerSample/swagger.json.
> Thanks
> Niten



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message