cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akitoshi Yoshida (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-6952) Swagger2Featue not scanning CXF resources
Date Fri, 01 Jul 2016 00:01:33 GMT

    [ https://issues.apache.org/jira/browse/CXF-6952?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15358071#comment-15358071
] 

Akitoshi Yoshida commented on CXF-6952:
---------------------------------------

You can try 3.1.5 or older or the 3.1.x or 3.2.x SNAPSHOT.
There was a jackson versioning issue in 3.1.6. which broke the simple karat-feature based
setup instruction given in its README.txt. (in other words, you would need to install appropriate
jackson bundles manually when you are using cxf 3.1.6 sample). The other versions of cxf sample
should work out of the box following the instruction.

Regarding a clean karaf, I mentioned it because if you have some conflicting bundles already
deployed, that could interfere with the simple setup.
If you start with a clean karaf and follow the sample instruction, you are sure that there
will be no conflicting bundles.

> Swagger2Featue not scanning CXF resources
> -----------------------------------------
>
>                 Key: CXF-6952
>                 URL: https://issues.apache.org/jira/browse/CXF-6952
>             Project: CXF
>          Issue Type: Bug
>          Components: JAX-RS
>    Affects Versions: 3.1.3, 3.1.5
>         Environment: Windows
>            Reporter: Niten Aggarwal
>              Labels: features
>
> Swagger2Feature is not scanning end points configured in OSGI blueprint and always returning
default Swagger Json. 
> To reproduce issue, I deployed https://github.com/apache/cxf/tree/master/distribution/src/main/release/samples/jax_rs/description_swagger2_osgi
project as well into my Karaf runtime but no luck and same default Json is returned.
> https://issues.apache.org/jira/browse/CXF-6524
> https://issues.apache.org/jira/browse/CXF-6541
> Was following above bugs and it seems with versions 3.0.6, 3.1.2 this issue should be
resolved so I tried with cxf versions 3.1.2, 3.1.3 and 3.1.5 but no luck.
> Also the samples distribution which is using 3.2.0-SNAPSHOT, also returns default json.
> Default json which I am getting..
> {"swagger":"2.0","info":{"description":"The Application","version":"1.0.0","title":"Sample
REST Application","contact":{"name":"users@cxf.apache.org"},"license":{"name":"Apache 2.0
License","url":"http://www.apache.org/licenses/LICENSE-2.0.html"}},"basePath":"/cxf/swaggerSample"}
> Also sample Json doesn't recognize base path and always returned at http://localhost:8181/swaggerSample/swagger.json.
> Thanks
> Niten



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message