cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niten Aggarwal (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CXF-6952) Swagger2Featue not scanning CXF resources
Date Sun, 26 Jun 2016 09:26:33 GMT
Niten Aggarwal created CXF-6952:
-----------------------------------

             Summary: Swagger2Featue not scanning CXF resources
                 Key: CXF-6952
                 URL: https://issues.apache.org/jira/browse/CXF-6952
             Project: CXF
          Issue Type: Bug
          Components: JAX-RS
    Affects Versions: 3.1.5, 3.1.3
         Environment: Windows
            Reporter: Niten Aggarwal


Swagger2Feature is not scanning end points configured in OSGI blueprint and always returning
default Swagger Json. 

To reproduce issue, I deployed https://github.com/apache/cxf/tree/master/distribution/src/main/release/samples/jax_rs/description_swagger2_osgi
project as well into my Karaf runtime but no luck and same default Json is returned.

https://issues.apache.org/jira/browse/CXF-6524
https://issues.apache.org/jira/browse/CXF-6541

Was following above bugs and it seems with versions 3.0.6, 3.1.2 this issue should be resolved
so I tried with cxf versions 3.1.2, 3.1.3 and 3.1.5 but no luck.

Also the samples distribution which is using 3.2.0-SNAPSHOT, also returns default json.

Default json which I am getting..
{"swagger":"2.0","info":{"description":"The Application","version":"1.0.0","title":"Sample
REST Application","contact":{"name":"users@cxf.apache.org"},"license":{"name":"Apache 2.0
License","url":"http://www.apache.org/licenses/LICENSE-2.0.html"}},"basePath":"/cxf/swaggerSample"}

Also sample Json doesn't recognize base path and always returned at http://localhost:8181/swaggerSample/swagger.json.

Thanks
Niten



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message