cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Mercer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-5483) Facing issue while deploying CXF 2.7.8 Rest Web service on Glassfish 4
Date Wed, 24 Feb 2016 17:21:18 GMT

    [ https://issues.apache.org/jira/browse/CXF-5483?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15163346#comment-15163346
] 

Patrick Mercer commented on CXF-5483:
-------------------------------------

Sergey / Devang, can you list the specific steps you did to "to exclude the http-jetty transport
component"?

I'm running in to the same error trying to deploy a very simple CXF (version does not seem
to matter) web service to a GlassFish 4.1.1 server and I'm not sure what I'm supposed to do
to exclude/disable/turn off the CXF http-jetty transport component.  Any help you can provide
will be much appreciated.

> Facing issue while deploying CXF 2.7.8 Rest Web service on Glassfish 4
> ----------------------------------------------------------------------
>
>                 Key: CXF-5483
>                 URL: https://issues.apache.org/jira/browse/CXF-5483
>             Project: CXF
>          Issue Type: Bug
>          Components: JAX-RS
>    Affects Versions: 2.7.8
>         Environment: Glassfih 4 & 3.1.2
>            Reporter: Devang Ganatra
>            Assignee: Sergey Beryozkin
>
> Hi,
> I want to deploy Rest Web Service created with CXF 2.7.8 to Glassfish 4. However I am
getting below error.
> Caused by: The lifecycle method [finalizeConfig] must not throw a checked exception.
Related annotation information: annotation [@javax.annotation.PostConstruct()] on annotated
element [public void org.apache.cxf.transport.http_jetty.JettyHTTPServerEngine.finalizeConfig()
throws java.security.GeneralSecurityException,java.io.IOException] of type [METHOD].
> I am able to load my application on Glassfish 3.1.2, however I want to use JAX-RS 2.0
and if I load my application on Glassfish 3.1.2 then it creates problem, because Glassfish
3.1.2 has Jersey1.x which implement JAXRS1.0. 
> So i would like to know weather CXF2.7.8 supports glassfish 4 or not? If it doesn't support
glassfish4 then how do I make sure that Glassfish 3 jersey implementation doesn't clash with
CXF JAX-RS implementation.
> I tried setting JVM option in glassfish 3, however that didn't work as well.
> <jvm-options>-Dcom.sun.enterprise.overrideablejavaxpackages=javax.ws.rs,javax.ws.rs.core,javax.ws.rs.ext</jvm-options>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message