cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Freeman Fang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-6710) CXF depends on jax-rs 2.0.1 but provides only 2.0.0 in its karaf bundle
Date Tue, 15 Dec 2015 11:15:46 GMT

    [ https://issues.apache.org/jira/browse/CXF-6710?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15057875#comment-15057875
] 

Freeman Fang commented on CXF-6710:
-----------------------------------

I think it's the default behavior to set the Import-Package version from dependencies version,
unless customer bundle use maven-bundle-plugin to specify Import-Package version explicitly
to override it.

> CXF depends on jax-rs 2.0.1 but provides only 2.0.0 in its karaf bundle
> -----------------------------------------------------------------------
>
>                 Key: CXF-6710
>                 URL: https://issues.apache.org/jira/browse/CXF-6710
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 3.1.4
>            Reporter: Benson Margulies
>
> org.apache.cxf:cxf-rt-frontend-jaxrs depends on javax.ws.rs:javax.ws.rs-api:jar:2.0.1,
but the feature includes org.apache.servicemix.specs.jsr339-api-2.0. So, either the version
range in the MANIFEST.MF needs to be tweaked, or the Karaf feature needs to be tweaked.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message