cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Beryozkin (JIRA)" <>
Subject [jira] [Commented] (CXF-6680) CXF above 3.0.5 throw NPE
Date Tue, 17 Nov 2015 14:11:10 GMT


Sergey Beryozkin commented on CXF-6680:

Hmm... I did peruse that stack trace yet again and I'm not sure if that Spring reporting about
POST is a red herring or not, perhaps CXF returned a not supported method. Unfortunately though
at this stage only yourself who can provide more info, start a remote debug session - put
few breakpoints (FormatInterceptor, your service code, and I guess in CXF JAXRSInInterceptor
and see what happens)

> CXF above 3.0.5 throw NPE
> -------------------------
>                 Key: CXF-6680
>                 URL:
>             Project: CXF
>          Issue Type: Bug
>          Components: JAX-RS
>    Affects Versions: 3.0.6, 3.0.7, 3.1.4
>            Reporter: Maƫl Lavault
>            Assignee: Sergey Beryozkin
>            Priority: Critical
> Hi,
> I tried to update to the last CXF release (3.1.4). Since I cannot launch my webapps.
After extensive testing, the last known release to work is 3.0.5 (for 3.1 branch, I only have
tested 3.1.4).
> I always get a NPE and a bunch of other errors (I pasted it on 0bin because the stack
is quite huge), I tried to follow step by step with the debugger but cannot find the root
> Any pointer is welcome !
> Thanks ! :)

This message was sent by Atlassian JIRA

View raw message