cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Gregory (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-6177) Update Apache HTTP async client to non-beta version 4.0.2
Date Tue, 24 Feb 2015 23:39:04 GMT

    [ https://issues.apache.org/jira/browse/CXF-6177?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14335672#comment-14335672
] 

Gary Gregory commented on CXF-6177:
-----------------------------------

FWIW, I am still on CXF 2.7 and not 3.x because Teiid's web service support is still on 2.7.11.
Our server depends directly on CXF and indirectly through Teiid. Sadly, since CXF kept the
same namespace between 2 and 3 even though the versions are NOT binary compatible, CXF 2 and
3 cannot coexist on the same classpath.

> Update Apache HTTP async client to non-beta version 4.0.2
> ---------------------------------------------------------
>
>                 Key: CXF-6177
>                 URL: https://issues.apache.org/jira/browse/CXF-6177
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.7.14
>            Reporter: Gary Gregory
>
> I cannot update to CXF 3.0.3 yet. Our internal release process has flagged our use of
CXF 2.7.10 as problematic due to the use of httpasyncclient-4.0-beta3.jar which has a known
security issue. I updated our server to CXF 2.7.14 but that still uses httpasyncclient-4.0-beta3.jar.
I would be great to update this to the released version: 4.0.2.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message