cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Schneider (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-6135) CXF should be installable in karaf 4 minimal
Date Fri, 05 Dec 2014 15:07:12 GMT

    [ https://issues.apache.org/jira/browse/CXF-6135?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14235580#comment-14235580
] 

Christian Schneider commented on CXF-6135:
------------------------------------------

Did another change now to make the http transport independent of pax web. The feature cxf-http
will now only install the servlet API and the http transport. So without pax web you can already
use the client side http transport. If you install pax web later the http transport will detect
the HttpService and install the CXF servlet which then enables the servlet transport.

> CXF should be installable in karaf 4 minimal
> --------------------------------------------
>
>                 Key: CXF-6135
>                 URL: https://issues.apache.org/jira/browse/CXF-6135
>             Project: CXF
>          Issue Type: Improvement
>            Reporter: Christian Schneider
>            Assignee: Christian Schneider
>             Fix For: 3.1.0
>
>
> Currently CXF can not be installed on plain karaf 4 minimal.
> There are two problems:
> 1. cxf-core bundle depends on the osgi blueprint spec
> 2. cxf-core feature installs the cxf-karaf-commands which require the old karaf shell
packages
> I propose to make the blueprint spec import optional and move the commands into a separate
feature.
> This will allow cxf to be installed with considerably less dependencies then the current
versions.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message