cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Schneider (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-6135) CXF should be installable in karaf 4 minimal
Date Thu, 04 Dec 2014 14:03:12 GMT

    [ https://issues.apache.org/jira/browse/CXF-6135?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14234215#comment-14234215
] 

Christian Schneider commented on CXF-6135:
------------------------------------------

Just tested the install after the changes. cxf-core then requires only 12 additional bundles
on karaf 4 minimal.


> CXF should be installable in karaf 4 minimal
> --------------------------------------------
>
>                 Key: CXF-6135
>                 URL: https://issues.apache.org/jira/browse/CXF-6135
>             Project: CXF
>          Issue Type: Improvement
>            Reporter: Christian Schneider
>            Assignee: Christian Schneider
>
> Currently CXF can not be installed on plain karaf 4 minimal.
> There are two problems:
> 1. cxf-core bundle depends on the osgi blueprint spec
> 2. cxf-core feature installs the cxf-karaf-commands which require the old karaf shell
packages
> I propose to make the blueprint spec import optional and move the commands into a separate
feature.
> This will allow cxf to be installed with considerably less dependencies then the current
versions.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message