cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CXF-5945) CXF 2.6.15 breaks Java SE 5 compatibility
Date Tue, 07 Oct 2014 18:11:33 GMT

     [ https://issues.apache.org/jira/browse/CXF-5945?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Kulp updated CXF-5945:
-----------------------------
    Fix Version/s: 2.6.16

> CXF 2.6.15 breaks Java SE 5 compatibility
> -----------------------------------------
>
>                 Key: CXF-5945
>                 URL: https://issues.apache.org/jira/browse/CXF-5945
>             Project: CXF
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.6.15
>            Reporter: Christoph E├čer
>            Priority: Critical
>             Fix For: 2.6.16
>
>
> With [commit a9cab01|https://github.com/apache/cxf/commit/a9cab01883cae2eff38abce30d846214a935b2f6],
CXF breaks Java SE 5 compatibility by using the method java.io.File.getUsableSpace() which
is introduced in Java SE 6. We depend on another critical fix in this version but we are also
bound to using Java 5 in our application server. 
> I know that 2.6.15 is planned to be the last release of that branch. However, is there
any option to release another version of the 2.6 branch without this newly introduced bug?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message