cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Björn Nebe (JIRA) <j...@apache.org>
Subject [jira] [Commented] (CXF-5977) Calling a WebService in a different domain ends up in UnknownHostException because the domain is lost
Date Fri, 29 Aug 2014 06:41:53 GMT

    [ https://issues.apache.org/jira/browse/CXF-5977?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14114936#comment-14114936
] 

Björn Nebe commented on CXF-5977:
---------------------------------

I am working with JDK 1.7.0_45 and tried different jars from 2.3 to 2.7.12

> Calling a WebService in a different domain ends up in UnknownHostException because the
domain is lost
> -----------------------------------------------------------------------------------------------------
>
>                 Key: CXF-5977
>                 URL: https://issues.apache.org/jira/browse/CXF-5977
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.3, 2.4, 2.5, 2.6, 2.7.12
>            Reporter: Björn Nebe
>         Attachments: Stacktrace.txt, codeexample.txt, part1.png, part2.png
>
>
> I have a client in one domain and a JBoss Application Server providing a WebService in
a different domain. Calling the WebService ends up in a UnknownHostException, because during
the read of the WSDL the domain part of the servername gets lost and the pure servername is
not known. I debugged threw this and add the Stacktrace of the resulting exception and two
screenshots showing in which member the wrong value can be found. If I change this member
in memory by eclipse, the call works. 



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message