cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Klapste (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CXF-5955) Wrong JAXB version used in JDK 1.7 with Maven 3.2.x
Date Fri, 15 Aug 2014 14:48:22 GMT
Jason Klapste created CXF-5955:
----------------------------------

             Summary: Wrong JAXB version used in JDK 1.7 with Maven 3.2.x
                 Key: CXF-5955
                 URL: https://issues.apache.org/jira/browse/CXF-5955
             Project: CXF
          Issue Type: Bug
          Components: Tooling
    Affects Versions: 2.7.12
         Environment: OSX
JDK 7u55, 7u60, 7u65
Maven 3.0.5, 3.1.1, 3.2.1, 3.2.2
            Reporter: Jason Klapste
            Priority: Minor


Under Maven 3.0.5 and 3.1.1, the following JAXB dependency versions are pulled in under JDK
1.7:

{noformat}
[INFO] +- org.apache.cxf:cxf-rt-core:jar:2.7.12:compile
[INFO] |  +- org.apache.cxf:cxf-api:jar:2.7.12:compile
[INFO] |  |  +- org.codehaus.woodstox:woodstox-core-asl:jar:4.4.0:compile
[INFO] |  |  |  \- org.codehaus.woodstox:stax2-api:jar:3.1.4:compile
[INFO] |  |  \- wsdl4j:wsdl4j:jar:1.6.3:compile
[INFO] |  +- com.sun.xml.bind:jaxb-impl:jar:2.2.6:compile
{noformat}

Under Maven 3.2.1 and 3.2.2, it seems the Maven profile "jdk17" is not being activated:

{noformat}
[INFO] +- org.apache.cxf:cxf-rt-core:jar:2.7.12:compile
[INFO] |  +- org.apache.cxf:cxf-api:jar:2.7.12:compile
[INFO] |  |  +- org.codehaus.woodstox:woodstox-core-asl:jar:4.4.0:compile
[INFO] |  |  |  \- org.codehaus.woodstox:stax2-api:jar:3.1.4:compile
[INFO] |  |  \- wsdl4j:wsdl4j:jar:1.6.3:compile
[INFO] |  +- com.sun.xml.bind:jaxb-impl:jar:2.1.13:compile
{noformat}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message