cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mandy Warren (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CXF-5690) Upgrade cxf-rt-transports-http-hc to depend on latest release of httpasyncclient
Date Tue, 15 Apr 2014 17:53:16 GMT
Mandy Warren created CXF-5690:
---------------------------------

             Summary: Upgrade cxf-rt-transports-http-hc to depend on latest release of httpasyncclient
                 Key: CXF-5690
                 URL: https://issues.apache.org/jira/browse/CXF-5690
             Project: CXF
          Issue Type: Wish
          Components: Transports
    Affects Versions: 2.7.11
            Reporter: Mandy Warren
            Priority: Minor


When I bring in the cxf-rt-transports-http-hc Maven dependency I get the following dependency
convergence errors (we use the maven-enforcer):-

[ERROR] +-org.apache.httpcomponents:httpclient:4.2.5
[ERROR] +-org.apache.httpcomponents:httpcore:4.2.4
[ERROR] and
[ERROR] +-org.apache.cxf:cxf-rt-transports-http-hc:2.7.11
[ERROR] +-org.apache.httpcomponents:httpcore-nio:4.2.4
[ERROR] +-org.apache.httpcomponents:httpcore:4.2.4
[ERROR] and
[ERROR] +-org.apache.cxf:cxf-rt-transports-http-hc:2.7.11
[ERROR] +-org.apache.httpcomponents:httpasyncclient:4.0-beta3
[ERROR] +-org.apache.httpcomponents:httpcore:4.2.2
[ERROR] ,

[ERROR] +-org.apache.cxf:cxf-rt-transports-http-hc:2.7.11
[ERROR] +-org.apache.httpcomponents:httpcore-nio:4.2.4
[ERROR] and
[ERROR] +-org.apache.cxf:cxf-rt-transports-http-hc:2.7.11
[ERROR] +-org.apache.httpcomponents:httpasyncclient:4.0-beta3
[ERROR] +-org.apache.httpcomponents:httpcore-nio:4.2.2

I fix this by adding the following exclusions:-
         <exclusions>
                <exclusion>
                    <groupId>org.apache.httpcomponents</groupId>
                    <artifactId>httpcore-nio</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>org.apache.httpcomponents</groupId>
                    <artifactId>httpcore</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>commons-logging</groupId>
                    <artifactId>commons-logging</artifactId>
                </exclusion>
            </exclusions>

and then adding in the following explicit dependencies:-
     <dependency>
            <groupId>org.apache.httpcomponents</groupId>
            <artifactId>httpcore</artifactId>
            <version>4.2.4</version>
            <scope>test</scope>
        </dependency>
        <dependency>
            <groupId>org.apache.httpcomponents</groupId>
            <artifactId>httpcore-nio</artifactId>
            <version>4.2.4</version>
            <scope>test</scope>
        </dependency>

It's not a big deal but wondered if you could depend on the latest release version of httpasyncclient?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message