cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aki Yoshida (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-5611) [joda-time] different versions in maven and feature descriptor
Date Thu, 13 Mar 2014 17:37:53 GMT

    [ https://issues.apache.org/jira/browse/CXF-5611?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13933600#comment-13933600
] 

Aki Yoshida commented on CXF-5611:
----------------------------------

I don't know why you have the range [2.2,3).
I just checked the current 2.7.11-SNAPSHOT, cxf-rt-security has org.joda.time;version="[1.6,3)".


> [joda-time] different versions in maven and feature descriptor
> --------------------------------------------------------------
>
>                 Key: CXF-5611
>                 URL: https://issues.apache.org/jira/browse/CXF-5611
>             Project: CXF
>          Issue Type: Bug
>          Components: Build system
>    Affects Versions: 2.7.11
>            Reporter: Alexey Markevich
>
> I have a project which depends on cxf-rt-security [1]. After the build there is 
> Import-Package: org.joda.time;version="[2.2,3)"
> But after deploy to karaf got
> Reason: Missing Constraint: Import-Package: org.joda.time; version="[2.2.0,3.0.0)"
> because wss4j feature contains [2]
> 1.
> [INFO] \- org.apache.cxf:cxf-rt-security:jar:2.7.11-SNAPSHOT:compile
> [INFO]    +- org.opensaml:opensaml:jar:2.6.1:compile
> [INFO]    |  +- joda-time:joda-time:jar:2.2:compile
> 2.
> <bundle start-level='25' dependency="true">mvn:joda-time/joda-time/2.1</bundle>



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message