cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CXF-5522) xs:string content not correctly escaped
Date Sat, 25 Jan 2014 22:33:39 GMT

    [ https://issues.apache.org/jira/browse/CXF-5522?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13882086#comment-13882086
] 

Daniel Kulp edited comment on CXF-5522 at 1/25/14 10:33 PM:
------------------------------------------------------------

It is not a problem to have <'s escaped and > not.  It is still valid XML.   You can
have something like:
{code}
<foo>2 > 1 || 1 &lt; 2</foo>
or
<foo>1 &lt; 2 || 2 > 1</foo>
{code}
that's perfectly valid XML.  


was (Author: dkulp):
It is not a problem to have <'s escaped and > not.  It is still valid XML.   You can
have something like:

<foo>2 > 1 || 1 &lt; 2</foo>
or
<foo>1 &lt; 2 || 2 > 1</foo>

that's perfectly valid XML.  

> xs:string content not correctly escaped
> ---------------------------------------
>
>                 Key: CXF-5522
>                 URL: https://issues.apache.org/jira/browse/CXF-5522
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.7.5
>            Reporter: Alex O'Ree
>            Assignee: Daniel Kulp
>             Fix For: Invalid
>
>
> I have a jaxws service in which the content of the string actually includes xml. All
of the < symbols are correctly escaped, however the > symbols are not. 



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message