cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mahesh Narke (JIRA)" <>
Subject [jira] [Created] (CXF-5474) The message has expired
Date Mon, 23 Dec 2013 08:44:50 GMT
Mahesh Narke created CXF-5474:

             Summary: The message has expired
                 Key: CXF-5474
             Project: CXF
          Issue Type: Bug
          Components: JAX-WS Runtime, WS-* Components
    Affects Versions: 2.7.9
         Environment: Environment :
Apache CXF 2.7.8
Jboss EAP 6
SoapUI for testing client Side
            Reporter: Mahesh Narke
             Fix For: 2.7.9

I tried to implement for simple authentication i.e with password simple text type, it is working
but when i tried to implement for password digest type ,then giving me exception:

unwinding now: org.apache.cxf.binding.soap.SoapFault: The message has expired
The message has expired

I am giving new nonce value for each request and time within five min diff

WSS4JInInterceptor Bean class defination:

<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns=""

    <import resource="classpath:META-INF/cxf/cxf.xml" /> 
    <import resource="classpath:META-INF/cxf/cxf-extension-soap.xml" />
    <import resource="classpath:META-INF/cxf/cxf-servlet.xml" /> 

    <jaxws:endpoint id="orderProcess" implementor="demo.order.OrderProcessImpl" address="/OrderProcess"

                  <entry key="action" value="UsernameToken"/>
                  <entry key="passwordType" value="PasswordDigest"/>
                  <entry key="passwordCallbackRef" value-ref="myPasswordCallback"/>
      <bean id="myPasswordCallback" class="service.ServerPasswordCallback" />  

Client xml request Code:


                                <wsse:Password Type="">PE7F51/oyWFVMsiZURuUwjoZVPY=</wsse:Password>
                           <wsse:Nonce EncodingType="">efPSkfHXTM6NFDDD1CJHsw==</wsse:Nonce>

When i tried to call the service i am getting exception as

<soap:Envelope xmlns:soap="">
         <faultcode xmlns:ns1="">ns1:MessageExpired</faultcode>
         <faultstring>The message has expired</faultstring>

Can any one tell me where i am making mistake?

This message was sent by Atlassian JIRA

View raw message