cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CXF-5456) Generated "Impls" should be based off the service/port, not portType
Date Wed, 11 Dec 2013 20:40:07 GMT
Daniel Kulp created CXF-5456:
--------------------------------

             Summary: Generated "Impls" should be based off the service/port, not portType
                 Key: CXF-5456
                 URL: https://issues.apache.org/jira/browse/CXF-5456
             Project: CXF
          Issue Type: Bug
    Affects Versions: 3.0.0-milestone1
            Reporter: Daniel Kulp
            Assignee: Daniel Kulp
             Fix For: 3.0.0-milestone2



The generated impls have the service name and port name burned into the @WebService annotation.
 Thus, they should be named according to the port name, not the portType.  This would avoid
the semi-unpredictable:

FooPortTypeImpl.java
FooPortTypeImpl1.java
....

and have things like:
FooSOAP11PortImpl.java
FooSOAP12PortImpl.java
....





--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message