cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aki Yoshida (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-5446) systests/jaxrs tests sometimes hang in CI
Date Mon, 23 Dec 2013 12:59:50 GMT

    [ https://issues.apache.org/jira/browse/CXF-5446?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13855613#comment-13855613
] 

Aki Yoshida commented on CXF-5446:
----------------------------------

we ran several tests and here the irc transcription recaps the tests.
http://irclogs.dankulp.com/logs/irclogger_log/cxf?date=2013-12-20,Fri&sel=144#l140

We observed this problem very frequently on one of our jenkins (SUSE Linux 2.6.34.10-0.6-xen)
but not on another jenkins (RHE Linux 2.6.32-220.2.1.el6.x86_64) nor on a couple of OSX or
Win7-x64 boxes we tried. 

Initially, I thought this was some jenkins related issue. However, I could reproduce this
problem on another Linux desktop (SUSE Linux version 2.6.34.8-0.2-desktop). As Sergey was
not getting this problem on his Ubuntu (Linux version 3.2.0-56-generic),  I upgraded this
desktop to a more recent Ubuntu 12.04.3 LTS (Linux 3.2.0-57-generic-pae) to see if the problem
disappears. However, the problem persisted and even after upgrading to Ubuntu 12.10 (Linux
version 3.5.0-44-generic) but the problem remained with all JDKs tried (6 and 7 Open- and
Oracle JDKs).

So, if you want to reproduce this problem, I think you can grab the current ubuntu distro
(12.04.03 or 12.10) and can reproduce this problem.

Aki


> systests/jaxrs tests sometimes hang in CI
> -----------------------------------------
>
>                 Key: CXF-5446
>                 URL: https://issues.apache.org/jira/browse/CXF-5446
>             Project: CXF
>          Issue Type: Bug
>            Reporter: Kevin Earls
>            Priority: Minor
>              Labels: test
>         Attachments: CXF-5446.patch
>
>
> I've seen at least the following 2 tests hang
> JAXRS20ClientServerBookTest
> JAXRSAsyncClientTest
> I will attach a patch which adds timeouts



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message