cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vishal Balana (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CXF-5385) CXF 2.7.7 on Websphere 8.5.0 is not able to generate WADL.
Date Thu, 14 Nov 2013 19:29:21 GMT
Vishal Balana created CXF-5385:
----------------------------------

             Summary: CXF 2.7.7 on Websphere 8.5.0 is not able to generate WADL.
                 Key: CXF-5385
                 URL: https://issues.apache.org/jira/browse/CXF-5385
             Project: CXF
          Issue Type: Bug
          Components: JAX-RS
    Affects Versions: 2.7.7
         Environment: Websphere 8.5.0, IDE: RAD 8.5.5
            Reporter: Vishal Balana
             Fix For: 2.7.7


Following exception occurs while trying to get the WADL out of HelloWorld app deployed on
Wehbsphere 8.5.0.

When I tried with CXF 2.7.3, it worked Fine! 2.7.4, 2.7.5, 2.7.6 and 2.7.7 all spits the following
exception.

com.ibm.ws.webcontainer.servlet.ServletWrapper service Uncaught service() exception thrown
by servlet appServlet: java.lang.NoSuchMethodError: javax/ws/rs/core/Response.getHeaders()Ljavax/ws/rs/core/MultivaluedMap;
	at org.apache.cxf.jaxrs.utils.JAXRSUtils.setMessageContentType(JAXRSUtils.java:1587)
	at org.apache.cxf.jaxrs.JAXRSInvoker.checkExchangeForResponse(JAXRSInvoker.java:281)
	at org.apache.cxf.jaxrs.JAXRSInvoker.invoke(JAXRSInvoker.java:82)
	at org.apache.cxf.interceptor.ServiceInvokerInterceptor$1.run(ServiceInvokerInterceptor.java:57)
	at org.apache.cxf.interceptor.ServiceInvokerInterceptor.handleMessage(ServiceInvokerInterceptor.java:93)
	at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:272)
	at org.apache.cxf.transport.ChainInitiationObserver.onMessage(ChainInitiationObserver.java:121)
	at org.apache.cxf.transport.http.AbstractHTTPDestination.invoke(AbstractHTTPDestination.java:239)
	at org.apache.cxf.transport.servlet.ServletController.invokeDestination(ServletController.java:248)
	at org.apache.cxf.transport.servlet.ServletController.invoke(ServletController.java:222)
	at org.apache.cxf.transport.servlet.ServletController.invoke(ServletController.java:153)
	at org.apache.cxf.transport.servlet.CXFNonSpringServlet.invoke(CXFNonSpringServlet.java:167)
	at org.apache.cxf.transport.servlet.AbstractHTTPServlet.handleRequest(AbstractHTTPServlet.java:286)
	at org.apache.cxf.transport.servlet.AbstractHTTPServlet.doGet(AbstractHTTPServlet.java:211)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:575)



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message