cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Beryozkin (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CXF-5309) Support Bean Validation API for JAX-RS
Date Tue, 26 Nov 2013 10:14:37 GMT

    [ https://issues.apache.org/jira/browse/CXF-5309?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13832465#comment-13832465
] 

Sergey Beryozkin edited comment on CXF-5309 at 11/26/13 10:14 AM:
------------------------------------------------------------------

Hi Andriy, All,

I was wondering if we should rename all validation interceptors and add 'Bean' into the names.
Example, we have ValidationInInterceptor, ValidationOutInterceptor, ValidationFeature, etc.
CXF also supports the schema validation. So 'BeanValidationInInterceptor',  etc would read
better/clearer. Any objections if I rename the current interceptors, before we start documenting
it ?  
Sergey


was (Author: sergey_beryozkin):
Hi Andriy, All,

I was wondering if we should rename all validation interceptors and add 'Bean' into the names.
Example, we have ValidationInInterceptor, ValidationOutInterceptor, ValidationFeatire, etc.
CXF also supports the schema validation. So 'BeanValidationInInterceptor',  etc would read
better/clearer. Any objections if I rename the current interceptors, before we start documenting
it ?  
Sergey

> Support Bean Validation API for JAX-RS
> --------------------------------------
>
>                 Key: CXF-5309
>                 URL: https://issues.apache.org/jira/browse/CXF-5309
>             Project: CXF
>          Issue Type: Sub-task
>          Components: JAX-RS, JAX-WS Runtime
>            Reporter: Sergey Beryozkin
>            Assignee: Sergey Beryozkin
>             Fix For: 3.0.0-milestone1
>
>         Attachments: patch-jaxrsvalidationinvoker-tests.txt, patch-validation-exception-mapper.txt,
patch-validation-paramnameprovider.txt, patch-validation-poc.txt, patch-validation-spring-tests.txt,
patch-validation-tests.txt
>
>




--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message