cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Freeman Fang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-5019) Features XML does not load up correctly
Date Thu, 16 May 2013 00:55:16 GMT

    [ https://issues.apache.org/jira/browse/CXF-5019?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13659093#comment-13659093
] 

Freeman Fang commented on CXF-5019:
-----------------------------------

Hi,

The Karaf 2.2.x etc/jre.properties.cxf was well tested and worked with older CXF versions.
Now we encourage users to use latest Karaf 2.3.x, which support CXF OOTB, no need to use etc/jre.properties.cxf
 anymore.

Back to the issue you encounter, you need replaces the etc/jre.properties with the etc/jre.properties.cxf,
also edit this file and  uncomment 
 javax.jws, \
 javax.jws.soap, \

for jre-1.7 property, then it can work with latest CXF 2.7.x.

Freeman
                
> Features XML does not load up correctly
> ---------------------------------------
>
>                 Key: CXF-5019
>                 URL: https://issues.apache.org/jira/browse/CXF-5019
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.7.5
>         Environment: Karaf 2.2.11
>            Reporter: Archimedes Trajano
>
> When adding 2.7.5 features.xml on a clean Karaf installation and installing it will yield
the following error.
> karaf@root> features:addUrl mvn:org.apache.cxf.karaf/apache-cxf/2.7.5/xml/featur
> es
> karaf@root> features:install cxf
> Error executing command: Could not start bundle mvn:org.apache.cxf/cxf-api/2.7.5
>  in feature(s) cxf-core-2.7.5: Uses constraint violation. Unable to resolve modu
> le org.apache.cxf.cxf-api [81.0] because it is exposed to package 'javax.activat
> ion' from modules org.apache.servicemix.specs.activation-api-1.1 [88.0] and org.
> apache.felix.framework [0] via two dependency chains.
> Chain 1:
>   org.apache.cxf.cxf-api [81.0]
>     import: (&(package=javax.activation)(version>=0.0.0)(!(version>=2.0.0)))
>      |
>     export: package=javax.activation
>   org.apache.servicemix.specs.activation-api-1.1 [88.0]
> Chain 2:
>   org.apache.cxf.cxf-api [81.0]
>     import: (&(package=javax.mail.internet)(version>=1.4.0)(!(version>=2.0.0)))
>      |
>     export: package=javax.mail.internet; uses:=com.sun.mail.util
>   javax.mail [72.0]
>     import: (&(package=com.sun.mail.util)(version>=1.4.0))
>      |
>     export: package=com.sun.mail.util; uses:=javax.mail
>   javax.mail [90.0]
>     import: (&(package=javax.mail)(version>=1.4.0))
>      |
>     export: package=javax.mail; uses:=javax.activation
>   javax.mail [72.0]
>     import: (package=javax.activation)
>      |
>     export: package=javax.activation
>   org.apache.felix.framework [0]
> karaf@root>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message