cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Freeman Fang (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CXF-4926) remove org.apache.activemq.activemq-core as Require-Bundle from wsn-core module
Date Wed, 27 Mar 2013 08:57:17 GMT

     [ https://issues.apache.org/jira/browse/CXF-4926?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Freeman Fang resolved CXF-4926.
-------------------------------

       Resolution: Fixed
    Fix Version/s: 2.5.10
                   2.6.7
                   2.7.4
                   2.8.0

commit fix
http://svn.apache.org/r1461441 for trunk
http://svn.apache.org/r1461446 for 2.7.x branch
http://svn.apache.org/r1461451 for 2.6.x branch
http://svn.apache.org/r1461453 for 2.5.x branch
                
> remove org.apache.activemq.activemq-core as Require-Bundle from wsn-core module
> -------------------------------------------------------------------------------
>
>                 Key: CXF-4926
>                 URL: https://issues.apache.org/jira/browse/CXF-4926
>             Project: CXF
>          Issue Type: Improvement
>            Reporter: Freeman Fang
>            Assignee: Freeman Fang
>             Fix For: 2.8.0, 2.7.4, 2.6.7, 2.5.10
>
>
> currently wsn-core depend org.apache.activemq.activemq-core as Require-Bundle, this bind
cxf wsn to a certain bundle, Activemq 5.8 now has no  org.apache.activemq.activemq-core anymore(there's
a org.apache.activemq.activemq-osgi instead), so that cxf-wsn won't work in the OSGi container
which install Activemq 5.8.
> We better use Import-Package but not Require-Bundle here.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message